Mastodon Mail Delivery Issues

Incident Report for PrivacyTools

Resolved

This incident has been resolved.
Posted Apr 16, 2020 - 15:49 UTC

Investigating

We are aware of an issue with Mastodon email delivery.
Posted Apr 16, 2020 - 15:34 UTC
This incident affected: Community Services (Mastodon).