Mailserver Offline
Incident Report for PrivacyTools
Resolved
This incident has been resolved.
Posted Jun 20, 2020 - 06:00 UTC
Investigating
We are currently investigating this issue.
Posted Jun 20, 2020 - 05:38 UTC
This incident affected: Private Services (Email).